Aurelia UX - Test App problem

I am trying to run the Aurelia UX test app. The instructions say:

Run a test app which emulates dependencies installation

To run the test app, first make sure you built all the packages via the instruction of how to build above. Then open a shell at root of this project and copy paste the following:

cd app
npm ci
npm run dev

npm ci gives me this error:

npm WARN prepare removing existing node_modules/ before installation
npm ERR! cipm can only install packages when your package.json and package-lock.json or npm-shrinkwrap.json are in sync. Please update your lock file with npm install before continuing.
npm ERR!
npm ERR!
npm ERR! Missing: @aurelia-ux/lookup@file:…/packages/lookup
npm ERR! Missing: @aurelia-ux/tree-view@file:…/packages/tree-view
npm ERR!

Can anyone suggest how to get this working?

1 Like

I deleted the package-lock.json file, and tried again and it worked.


Probably we will remove this section

since we dont need it, since we are referencing source code directly anyway. Could help avoid situations like this.

@bigopon - how do I add a reference to the new @aurelia-ux/tabs that I am adding, so that the Test App can use it?

1 Like

You can have a look at how other packages are added, that’s the only place needed. For TS, we have mapping in tsconfig.json

Don’t forget to add an alias in webpack config as well

1 Like

Thanks @MaximBalaganskiy - I just discovered that, after 90 minutes of banging my head against the desk :wink:

1 Like

Can we peek at the tabs yet? :slight_smile:

1 Like

Sorry, I’m still in very early stages. I’m trying to get my head around what others have done, and how much I can re-use and/or copy. I’ll continue to post to as I get something running in my forked copy.

1 Like