Aurelia v1 change detection not working


I have a problem with change detection not working properly.
Expressions like


are not reevaluated even when I change the values from callback. (I tried also creating new object, so the reference would change).

I tried using signals and it seems to work, at least for these simple expressions, but it doesn’t work for <compose>.

This works:

${composedViewPath & signal: 'server-settings-editor-view'}

But not here:

<compose"getActiveTab(composedViewPath) & signal: 'server-settings-editor-view'"  model.bind="model & signal: 'server-settings-editor-view'">

Unfortunately I’m unable to create some small example on how to reproduce this issue.
I guess problem must be deeper in my application.

Could anyone please help me with debugging? I’m not quite sure where to look :frowning:
So far I have noticed SetterObserver.setterValue is being properly called, but it ends on condition this.queued which is true. I guess something happens with the task queue and it has some task stuck which prevents other tasks from getting into queue and properly evaluating the changes. But then I don’t understand how is it possible that the signal works…