Esbuild-loader / webpack / Aurelia

In one the newsletters I read an interesting post was added about ESBuild, and the enormous improvement of buildspeed compared to several other packers/minifiers including Webpack.
Although webpack supports many features, we experience build times of over 1 minute in our project. But unfortunately a small test with the esbuild-loader in webpack showed many errors for now
image

Q: are there developers out there that have investigate webpack / tsloader alternatives like esbuild and e.g. Snowpack? Or are there other working (quick)fixes for Aurelia 1?

Links:
esbuild: https://github.com/evanw/esbuild
esbuild-loader: https://github.com/privatenumber/esbuild-loader
snowpack: https://www.snowpack.dev/

1 Like

Another thing you can try is https://swc.rs which is quite popular (deno uses it too), it’s written in rust. It got a webpack loader too.

2 Likes

Thanks, will look into that one as well. But nobody out there that actually has changed the loader in the Aurelia build with Webpack, or perhaps has removed Webpack totally?

1 Like

Ad:

There is also dumber bundler I wrote to replace our CLI built-in bundler. I am using it on all my production apps with Aurelia 1.

It’s not selling speed but smallness and flexibility, although the speed is decent. It reduced bundling to a tiny step in gulp pipeline .pipe(dr()), leave all other things to the gulp ecosystem.

There is no official skeleton for Aurelia 1, but you can do npx makes dumberjs and choose Aurelia.
There is official skeleton for Aurelia 2, just do npx makes aurelia and choose custom -> dumber.

I am maintaining both of the above skeletons.

4 Likes

https://github.com/brandonseydel/aurelia-snowpack

Snowpack update breaks plugin.js

Seems to be not working with latest versions, any plans to make it work with latest version of Aurelia 2 (alpha) and snowpack?

I tried my self making this work by taking the @brandonseydel 's repo as reference

Git repo: aurelia-snowpack-plugin

While using the plugin in the application I get error.

1 Like

@brandonseydel

I tried with https://vitejs.dev/ as well, as it is a framework-agnostic development tool now.

but similar (I think) error.

When I see the error closly it says no such file or directory, (wron path C:\Users\prave\p\au2\au2-vite\au2-app\src@aurelia\runtime-html). Seems like npm packages are not referred from node_modules directory, instead it is reffered from /src.
I have no clue why.

Please let me know if someone can help to solve this problem.

I have updated the github repo to work with latest.

3 Likes