[solved] Trouble with binding functions and old code

Back in 2016 (? ish) this code worked

      <div class="info-pair">
        <span class="info-tag">is print:</span>
          id="is-print" type="radio" class="info-value" 
          name="blockSpecialType" value="isPrint" 

        <span class="info-tag">is cancel:</span>
          id="is-cancel" type="radio" class="info-value" 
          name="blockSpecialType" value="isCancel" 

Now using the top of Aurealia 1 the binding functions are being called & logging - but the Radio’s don’t change?

Its weird that it was working since isPrint() wont be tracked and the radio likely wont be updated properly.
Can you help with a repro for the issue? You can use this link to create a gist based repro https://gist.dumber.app/

If it was a glitch/bug that it worked at all then I need to just stop and move on with doing it the right way.

The working set of data is a fairly complex object containing arrays of arrays of objects.

What’s the best practice for binding against such a beast ?

Found newer strata of binding that was working and sprayed it over the older stuff and all’s well

(that newer one was only dealing with clicks, and was using jQuery selections to set values on a subscription)

      <div class="info-pair"><span class="info-tag">style:</span><span class="info-value">
        <label class="info-label"><input ref="plain" type="radio" change.trigger="doPlain()">:Plain</label> &nbsp;
        <label class="info-label"><input ref="bold" type="checkbox" change.trigger="doBold()">:Bold</label> &nbsp;
        <label class="info-label"><input ref="italic" type="checkbox" change.trigger="doItalic()">:Italic</label> &nbsp;
        <label class="info-label"><input ref="underline" type="checkbox" change.trigger="doUnderline()">:Underlined</label> &nbsp;

1 Like