The aurelia 2 book


I’m trying to re-implement GitHub - Vheissu/the-aurelia-2-book: Code examples and extra learning exercises for The Aurelia 2 Book. that is not maintained.

Here is where I am : GitHub - dfroger/catstore: trying to reimplented the unmaintained

From the products page, clicking a link to the product page yields to the error:

Uncaught (in promise) Error: Neither the route 'product' matched any configured route at 'my-app/products' nor a fallback is configured for the viewport 'default' - did you forget to add 'product' to the routes list of the route decorator of 'products'?

any idea?

My problem with Aurelia 2 is that I can’t find any real world working example to study. Even the examples in aurelia repository are broken. And the documentation is far insufficient. I love the concepts in Aurelia, but I’m considering abandoning it, as I’m stuck everywhere.

I tried to get things working. The main problem I think is a bug in the Aurelia Router when useUrlFragmentHash is set to false (in main.ts). When I set this to true then (with some other changes) can get it working.

I also seems that the load=‘’ construct in the HTML files does not work when useUrlFragmentHash is set to true. So this must be changed to a href.

Can you please point to the exact chapter and/or the code fragment that triggers this error?

@Sayan751 In the book it’s in “Products Page” chapter. In Github example code it’s in chapter 11. (But I rewrite the code from scratch as they are so many errors).

@arjendeblok I had tried useUrlFragmentHash=false but without a success.

Thanks for reporting this. I see the issue. Will try to push a fix in coming days.


Look at my fork at arjendeblok/catstore: trying to reimplented the unmaintained
Specifically to the last three commits.


@arjendeblok thanks a lot, will looking at it soon!

FYI. The fix is now merged: fix(router-lite): navigation to routes configured in ancestor nodes by Sayan751 · Pull Request #1514 · aurelia/aurelia · GitHub


Thanks for the support!

Hi everyone, sorry. With the constant state of changes in the router, there was a period there when new routers were being merged in and whatnot where it wasn’t even worth trying to update. I’ve got some updates for all of the chapters and some rewrites.