Updating to aurelia-cli 0.33

I’ve tried, a number of ways, to update from aurelia-cli version 0.32 to 0.33 but not matter what, including uninstalling node/npm and roaming dirs, after I install aurelia-cli 0.33 it always shows version 0.32. I’m wanting to updrade to 0.33 so I can fire up a webpack 4 app.

I got you covered (-:
Had the same issue…
Now your quest starts:
if you are on windows, run where au in cmd-line
pretty much your quest ends right here… sorry

for *nix you have “which” command to find out the path of an executable

I’ve also made sure my package, inside \AppData\Roaming\npm\node_modules\aurelia-cli, is indeed 0.33.1. I run au -v and it still shows version 0.32.0. I’ve tried uninstalling node/npm and re-install. I’ve also tried …

npm uninstall -g aurelia-cli au
npm cache clean --force
npm install -g aurelia-cli@0.33.1

but still, it shows version 0.32.0 and au new creates a package.json with webpack 3.5??

@Alexander-Taran Ha! Well looky there. It’s also in C:\Programs??? what the heck?? Thanks for that!

Sorry for a quest to short…
I had it longer…

you can compare the notes here Bootstrap error on contact manager tutorial

I’ve had plenty of long quests over the years so it’s nice to have the occasional “short quest” :slight_smile: Thanks again.

That is actually a bad sign…
It tells me you’ve been a bad boy.
You’ve been probably running npm in an elevated command prompt (-:

I’m sure I have since I have to run it often due to other apps that require it. I didn’t know that running it as admin that it would do that. But I guess that makes sense since when elevated, you are at that point, not user x anymore :slight_smile: Thanks again, saved me much pain.

1 Like

I had a similar problem. These are the steps I used to fix it.

  1. uninstall node/npm
  2. delete the nodejs folder in C:\program files
  3. reinstall node/npm
  4. npm install -g aurelia-cli
1 Like