Upgraded my package.json and broke my project

#1

Hi there,

Trying to get back into this.

I thought I would bring my dormant project up to date with the belief I could run npm update and all would go swimmingly alack alas I have ended up with errors. I shall show the error and also the package.json so you can see the versions I am using.

Here is the error:
aurelia-logging-console.js:45 ERROR [app-router] Error: Expression ‘client.companyName&validate’ is not compatible with the validate binding-behavior.
at getPropertyInfo (aurelia-validation.js:68)

Here is my package.json
{
“dependencies”: {
“au-table”: “^0.1.14”,
“aurelia-animator-css”: “^1.0.4”,
“aurelia-api”: “^3.2.1”,
“aurelia-binding”: “^2.3.0”,
“aurelia-bootstrap”: “^0.1.20”,
“aurelia-bootstrapper”: “^2.3.3”,
“aurelia-dialog”: “^1.1.0”,
“aurelia-event-aggregator”: “^1.0.3”,
“aurelia-fetch-client”: “^1.8.2”,
“aurelia-framework”: “^1.3.1”,
“aurelia-loader-webpack”: “^2.2.1”,
“aurelia-mask”: “^1.5.1”,
“aurelia-pal”: “^1.8.2”,
“aurelia-router”: “1.5.0”,
“aurelia-templating”: “^1.10.2”,
“aurelia-validation”: “^1.4.0”,
“bootstrap”: “^3.4.1”,
“fetch”: “^1.1.0”,
“font-awesome”: “^4.7.0”,
“isomorphic-fetch”: “^2.2.1”,
“jquery”: “^3.3.1”,
“popper.js”: “^1.14.7”,
“tether”: “^1.4.5”,
“velocity-animate”: “^1.5.2”
},
“devDependencies”: {
@types/jquery”: “^3.3.29”,
@types/webpack-env”: “^1.13.9”,
“aspnet-webpack”: “^2.0.3”,
“aurelia-webpack-plugin”: “^2.0.0-rc.2”,
“css-loader”: “^0.28.11”,
“extract-text-webpack-plugin”: “^2.1.0”,
“file-loader”: “^0.11.1”,
“html-loader”: “^0.4.5”,
“json-loader”: “^0.5.4”,
“npm-install-webpack-plugin”: “^4.0.5”,
“style-loader”: “^0.16.1”,
“ts-loader”: “^3.5.0”,
“typescript”: “^2.9.2”,
“url-loader”: “^0.6.2”,
“webpack”: “^3.12.0”,
“webpack-bundle-analyzer”: “^2.13.1”,
“webpack-hot-middleware”: “^2.24.3”
},
“name”: “Jobsledger.API”,
“private”: true,
“version”: “0.0.0”

The project is a dotnet core project with an Aurelia front end.

I am hoping someone will see this and know how to fix it. It would have been nice to just upgrade and it all worked but it hasnt. Hope someone can help.

Simon

1 Like

#2

Can you try the following:

  1. delete package-lock.json
  2. delete node_modules
  3. run npm install
  4. rerun the app

It’s a bit unfortunate with package-lock and multiple modules

0 Likes

#3

Will do… Get back in a moment…

1 Like

#4

Your good!.. worked perfectly… Many thanks… :grin:

2 Likes