Aurelia CLI - au new Error

Can anyone tell what i have to do to solve this:

Installing project dependencies.
throw er; // Unhandled ‘error’ event

Error: write after end
at writeAfterEnd (_stream_writable.js:236:12)
at PassThrough.Writable.write (_stream_writable.js:287:5)
at PassThrough.Writable.end (_stream_writable.js:563:10)
at ReadEntry.entry.on (/usr/local/lib/nodejs/node-v8.11.2/lib/node_modules/aurelia-cli/node_modules/npm/node_modules/pacote/lib/extract-stream.js:19:41)
at emitOne (events.js:121:20)
at ReadEntry.emit (events.js:211:7)
at ReadEntry.emit (/usr/local/lib/nodejs/node-v8.11.2/lib/node_modules/aurelia-cli/node_modules/npm/node_modules/tar/node_modules/minipass/index.js:296:25)
at ReadEntry.[maybeEmitEnd] (/usr/local/lib/nodejs/node-v8.11.2/lib/node_modules/aurelia-cli/node_modules/npm/node_modules/tar/node_modules/minipass/index.js:249:12)
at ReadEntry.end (/usr/local/lib/nodejs/node-v8.11.2/lib/node_modules/aurelia-cli/node_modules/npm/node_modules/tar/node_modules/minipass/index.js:162:27)
at Unpack.[consumeBody] (/usr/local/lib/nodejs/node-v8.11.2/lib/node_modules/aurelia-cli/node_modules/npm/node_modules/tar/lib/parse.js:210:13)
at Unpack.[consumeChunkSub] (/usr/local/lib/nodejs/node-v8.11.2/lib/node_modules/aurelia-cli/node_modules/npm/node_modules/tar/lib/parse.js:391:40)
at Unpack.[consumeChunk] (/usr/local/lib/nodejs/node-v8.11.2/lib/node_modules/aurelia-cli/node_modules/npm/node_modules/tar/lib/parse.js:362:30)
at Unzip.(anonymous function).on.chunk (/usr/local/lib/nodejs/node-v8.11.2/lib/node_modules/aurelia-cli/node_modules/npm/node_modules/tar/lib/parse.js:291:59)
at emitOne (events.js:116:13)
at Unzip.emit (events.js:211:7)
at Unzip.emit (/usr/local/lib/nodejs/node-v8.11.2/lib/node_modules/aurelia-cli/node_modules/npm/node_modules/tar/node_modules/minipass/index.js:296:25)

Can’t even create a project…

When I have experienced this, it involved finding the /bin folder where the cli was installed, and blasting it, and re-installing it globally. npm u aurelia-cli, find (OS dependant) node /bin and blasting the aurelia-cli bin… for example on windows that might be


I also have found, in my case it when i missed or locally installed a aurelia-cli to the package.json…

Either way, hope it helps.

1 Like

I uninstall aurelia, downgrade npm to 5.6.0 and also i clean the cache with npm cache clean --force, and reinstal aurelia client, but still doesn’t work. I will try it once.

Thanks for the help! Is very frustrating can’t even create the project…

Theres something i did not tell, and its when i do the au new into a old project folder of aurelia that i made very months ago, it work… :face_with_raised_eyebrow:

What version of Node are you using? Have you tried downgrading that as well, I always had issues with v9 of any kind, v8 has worked for me, and v10.

Im using v8.11. You think thats the problem ?

Okey, i try with v8.11.2 and v10.3.0, and doesn’t work either.

Well, finally works! The problem was aurelia-cli v0.33.0, i downgrade to v0.32.0 and works fine!

Thanks for the help!

Glad to hear you got it fixed! :slight_smile:

Just to “surround” your findings from both ends: I am happily using Aurelia CLI (au) 033.1