"no local installation of Aurelia-CLI could be found"

Apologies for the basic nature of the question.

When I try to execute au run on a project that I created I get the following error:

PS C: \ Users \ [mydrive] \ hello-world> au run
Global aurelia-cli v3.0.1
The current directory is likely an Aurelia-CLI project, but no local installation of Aurelia-CLI could be found. (Do you need to restore node modules using npm install?)

I have done the steps from the quickstart on this site leading up to that point.

  • node - v (returns v12.16.1)
  • npm -v (returns 6.13.4)
  • npm install -g aurelia-cli
  • au -v (returns v3.0.1)
  • au new hello-world (does not prompt me for TypeScript vs ESNext as has been suggested, but does create folder structure)
  • cd hello-world
  • au run (presented with error shown at top of post)

I later did >npm install aurelia-cli (sans -g) to do it locally since “but no local installation” was in the error, wondering if the global install was just messed up but that didn’t resolve my problem either.

Does anyone have thoughts on what I should try next? The non-prompt of TypeScript vs ESNext I curious about and wondering if that is a clue as to what’s up. Otherwise the only other thing I can think of is something doesn’t want to work on my user folder in my drive. I do not know what the node modules the error message inquired about restoring are referring to.

Thanks for any advice!

Edit: I just updated node to v16.16.0 since I saw "node": ">=14.15.0" in my package.json and still no dice.

I know this is a basic question, but I couldn’t tell from your message if you simply tried npm install from your aurelia app directory. Did you try just a plain install of all the node_modules?

1 Like

Thank you for your response, there is no question too basic for me since I’m brand new with the framework. I hadn’t realized that npm had to be installed local to the app directory. I just tried this and my error was replaced by the following.

[Error: ENOENT: no such file or directory, scandir ‘C:\Users[myDir]\hello-world\aurelia_project\tasks’] {
errno: -4058,
code: ‘ENOENT’,
syscall: ‘scandir’,
path: ‘C:\Users\[myDir]\hello-world\aurelia_project\tasks’
}
Waiting for the debugger to disconnect…

I do see the node_modules folder in the project with many shown (~500). Just like the new error suggests there is no ‘tasks’ folder inside the aurelia_project folder so that error makes total sense. I just don’t know what step I missed that would create that subdirectory.

Aurelia projects aren’t really anything special when compared to a typical webpack JS/TS project, so you should be able to start the web server using npm run start. You can quickly see a full list of commands with npm run.

Try these and then post the result message.

I just tried what I think you suggested, npm run start, from the project directory. I get the same error as au run which can still be seen in my previous reply.

I think I’ve seen some info about deleting the package-lock.json file. Maybe I should try that.

Yeah you could always remove package-lock and the node_modules folder then reinstall with npm i. Could be packages didn’t install correctly.