Help with VS code and debugging

I would appreciate it if someone could help in getting debugging with VS code working. I’m not sure if it’s a problem with VS code or the cli.

I either get “unverified breakpoint”, or the breakpoint jumps to another line. I can’t even debug within the developer panel.

My setup is aurelia-cli 1.3.1 with require.js. (I tried upgrading the cli to v 2.0.0 but got all kinds of other problems).

All npm packages are up to date (yarn outdated/yarn upgrade).

I run the app from au build --watch

VS Code
Version: 1.49.0-insider (user setup)
Commit: e4256dd1a02339bb1d56647ecd9134bf38bc7c03
Date: 2020-09-04T18:49:12.955Z
Electron: 9.2.1
Chrome: 83.0.4103.122
Node.js: 12.14.1
OS: Windows_NT x64 10.0.19041

The code structure is

/wwwroot/scripts/*.bundle.js.* etc

I’m using Microsoft Edge (chrome) but have the same problem with Google Chrome.


 "configurations": [
      "trace": true,
      "name": "Launch Chrome",
      "request": "launch",
      "type": "pwa-chrome",
      "url": "https://localhost:5001",
      "webRoot": "${workspaceFolder}/src",
      "userDataDir": "${workspaceFolder}/.chrome",
      "sourceMapPathOverrides": {
        "/*": "${webRoot}/*"
      "name": "Launch Edge",
      "request": "launch",
      "type": "pwa-msedge",
      "url": "https://localhost:5001",
      "webRoot": "${workspaceFolder}/src"

I used to be able to run .scripts from the debugger but that no longer seems to work

1 Like

Pretty sure I got debugging working with v1, have a look at

1 Like