Resolved - Can't build production with aurelia-cli v2.0.3

I have aurelia-cli v2.0.3 installed globally on my machine.

I created a new .Net Core Web API project, added a ClientApp folder within the project. Then, within the ClientApp folder, I ran au new --here with the following options.

Now, within the ClientApp directory, I run au build --env prod and get the following:

Why can’t I build the default app created with the cli? Is there something wrong with v2.0.3 of the cli or am I just doing something wrong? (Incidentally, running in dev mode seems to work just fine.)

using npm v16.5.0, npm v8.3.0

Looks suspiciously like a Windows System path with spaces issue were there are missing quotes around it.

Agreed, but this is “straight out of the box” – I haven’t added one line of my own code to anything the cli generated. The project that I’m working with doesn’t contain any spaces in its full path so it doesn’t seem tied to my project.

It almost appears that au build is trying to use my global version of npm (which is installed in the Program Files directory. Not sure why its not using the local version.

Has anyone else had this problem with Windows and the v2.0.3 cli?

I finally figured it out. I was trying typing the following:

au build --env prod

When I should have been typing:

au build --env —prod