[SOLVED] Trying to deploy to gh-pages


#1

I am trying to get Aurelia working on GitHub Pages, as per the following 2 links:

I have deployed it, but I get a 404 for aurelia-bootstrapper.

It’s published here: https://gordon-matt.github.io/Extenso/

And my gh-pages branch is here: https://github.com/gordon-matt/Extenso/tree/gh-pages.

What am I doing wrong?


#2

You gh-pages was setup with repo name in the path /Extenso, that’s why all your css with absolute path do not work.

Change them to

<link rel="stylesheet" href="css/site.css" />
<link rel="stylesheet" href="css/splash.css" />
<link rel="stylesheet" href="css/prettify-visual-studio.css" />

You also need to change SystemJS baseURL in config.js to "/Extenso", since you use hash (not history api) in your router, you can simply do this.

System.config({
  // resolve to "/Extenso" for gh-page site
  // resolve to "/" for local dev
  baseURL: location.pathname,
  // ...
});

#3

Thanks for the response. I made the changes as you suggested, but I now get a 404 on the main.js. I tried changing the baseURL to location.pathname and then also hardcoded to /Extenso/, but both of these still give a 404, because it’s not looking in /Extenso for some reason. Confused…


#4

Nevermind - I think I see the problem:

<div aurelia-app="/aurelia-app/main">

Will try change that and any other places if needed and see what happens.


#5

OK, I’ve got it working now. Thanks for your help @huochunpeng .