Error : Can only load node core modules in Node

Hi all,
I’m working on an aurelia project started since 2015. I had to update the node version of it and ever since I’m facing lots of errors that I’ve solved. Now I’m stuck with this error :

Uncaught (in promise) Error: (SystemJS) Error loading @node/tty. Can only load node core modules in Node.
	TypeError: Error loading @node/tty. Can only load node core modules in Node.

I’ve tried to modify config.js, but nothing worked with me and I can’t find helpful resources about this error. Can anyone help please ?

Please describe your setup a bit more.
you were using skeleton as a starter?
and you settled on jspm, cos there were nothing else at the time.
on what version of node it worked?
what version do you have now?

The error happens in the browser?
What modules are loading when that happens?

  • The developer who started the project isn’t here anymore so I don’t know how he start it. I started to work on it only last year and it was smooth before getting to update node version.
  • jspm is used heavily, most of the packages are within it. I don’t know if this answers the question.
  • It was on node version v0.12.18 & it’s now updated to v6.9.1
  • Yes the error happens inside the browser I took it from its console.
  • I don’t know what modules are loading, how to check ?

Man, you got a lot of catching up to do…
I’d suggest you take the latest skeleton from here

not released but straight from master…
you probably need the skeleton-esnext.
I doubt that yours is set up with typescript.

Then ensure it (the skeleton) runs as it should after installing depelnedncies (npm/jspm/typings)

Then figure out what would be easier… moving code from your app to the skeleton, or upgrading dependencies in your app.

Ping back here if you’ll get stuck on the way.
And good luck.

1 Like