HELP! - Node Sass doesn't support Windows 64-bit

Hello,

I had a project that I started using aurelia-cli 1.3.1 (I don’t know what that means in terms of the framework version). I think I was using node 10.3.0 and npm 6.1.0 at the time. Everything compiled and worked just fine.

Recently, I started a new project. Prior to this project, I decided to upgrade the aurelia-cli as well as node/npm. So, I’ve now got aurelia-cli 2.0.3, node 16.5.0 and npm 7.20.3. The new project works great.

However, I now need to go back and make some changes to my older project. au build gives me the following error message:

Error: Node Sass does not yet support your current environment: Windows 64-bit with Unsupported runtime (93)

Checking my versions in the project directory yields:

au -v : Local aurelia-cli v.1.3.1
node -v : v16.5.0
npm -v : v7.23.3

If I use Node Version Manager to switch back to node 10.3.0 and try au build, I then get a message:

You are running Node.js v10.3.0
aurelia-cli requires Node.js v10.12.0 or above
Please upgrade to latest Node.js https://nodejs.org

So, I installed node 12.0.0 and ran au -v only to get

‘au’ is not recognized as an internal or external command.

If I change my node version to node 16.5.0 or node 10.3.0 then au -v works – but I still cannot build my old project.

What do I do now?

1 Like

Node sass is deprecated so there wont be a support for upcoming node versions Sass: LibSass is Deprecated

As suggested update to Dart sass npm i sass

1 Like

So, I fixed my current issue by doing the following:

  1. Installed node 10.24.1
  2. Set v.10.24.1 as my current node version
  3. Installed the older aurelia-cli npm install aurelia-cli@1.3.1 -g

Whew! Was sweating it there for a bit.

Thanks for the heads up on the Sass library being deprecated!

2 Likes

the other thing that you might have had problems with node-sass is that whenever you change (upgrade/downgrade) your NodeJS version it would fail and the only way to get it working again was to delete your entire node_modules folder and re-run an npm install and perhaps that was your issue. That is the only problem I always had with node-sass and I do run Windows 64 bits. I don’t think this problem is there anymore since I started using dart-sass, it’s written in Go and node-sass was written in C++ I think which was causing lot of build issues. dart-sass is a lot faster, totally worth the upgrade

1 Like

You don’t have to downgrade nodejs and aurelia-cli.

If you look at your package.json, the old app has “node-sass” in devDeps. Your new app instead will have “sass” in devDeps.

Remove “node-sass” from your old app’s package.json, and install “sass” instead.
npm uninstall node-sass
npm install -D sass

1 Like