Visual Studio 2017: Project file is incomplete. Expected imports are missing


#1

I have been away from Aurelia for a while, just updated the aurelia-cli and created a new dot-net based webpack project. It would not open in Visual Studio 2017. giving the error:

Project file is incomplete. Expected imports are missing.

Deleting ‘global.json’ file and opening again VS solved this. A minor inconvenience. Any reason why this happens?

UPDATE: I believe this is started after updating VS 2017 a few hours ago. Still not certain of definitive cause.


#2

Version of .net core in the global? Probably one you didn’t have. Deleting made it grab latest.


#3

We have had problems updating Visual Studio 2017 minor versions with Aurelia Net Core projects and therefore would not recommend upgrading unless you have tested everything works (perhaps on a test machine that does not matter if something breaks). A long series of Visual Studio 2017 minor versions upgrades is a sign they have been released too soon before satisfactory testing coverage and introduced subtle bugs. Major upgrades are generally better and far more reliable. The default new projects are now set up for Net Core 2.1 (significantly different to prior versions and the only one officially supported) and no doubt this will upgrade to 2.2 and 3.0 in due course.


#4

As @brandonseydel mentioned, the dotnet version referenced was different after updating. Executing dotnet --version and changing the version to that fixed things.